LS1 V8 280z

Show everyone your mean datto projects/rides
SRCooper
Committee Members
Posts: 147
Joined: Mon Feb 16, 2015 6:45 pm
Location: Christchurch

Re: LS1 V8 280z

Postby SRCooper » Wed Apr 18, 2018 6:04 pm

Dont think ill be getting the diff in for the weekend, it hasnt turned up yet, ended up with a 4.1 so should make it fun to drive. Also the bumper wont be finished as it needs a lot of glassing now its all cut up. Wof tomorrow
You wouldn't have that problem with a V8!!!!

SRCooper
Committee Members
Posts: 147
Joined: Mon Feb 16, 2015 6:45 pm
Location: Christchurch

Re: LS1 V8 280z

Postby SRCooper » Wed May 09, 2018 7:46 pm

Been waiting on steel for the front bumper, just got it today so can carry on with that. Also got a new steering wheel so if anyones after my old one ill sell it cheap.
You do not have the required permissions to view the files attached to this post.
You wouldn't have that problem with a V8!!!!

SRCooper
Committee Members
Posts: 147
Joined: Mon Feb 16, 2015 6:45 pm
Location: Christchurch

Re: LS1 V8 280z

Postby SRCooper » Sat Jun 09, 2018 10:12 am

SO lots has been happening but just no time to update the build thread, So ive got the bumper all done which im pretty happy with just need to sand it back and fill a couple of holes then repaint, secondly i got some headlight covers from DJZ which look awesome on it i recon and they dont effect the lights at all, I took this up to Nelson on queens birthday weekend and had nothing but trouble, it started off with it running on 7 cylinders the whole way up (still went well just stumbled at low revs) so when i got up there i swapped out one of the injectors which helped it but on the way back from the test run my steering jammed up on a corner, luckly i managed to break it free and carefully drive it back to the place i was staying at. After spending the night thinking of what it could be i spent sunday stripping the engine bay down to remove the steering box of which i found a bolt had snapped off inside and the parts were all jamming inside it. so that went back together with all the parts out so i could drive it home, I missed the cruise i had planned up there (even though no one was turning up) so now the steering box is out getting modified and i still have a misfire, ive compression checked the engine and found one spark plug is oil fouled, so might be stripping the heads
You do not have the required permissions to view the files attached to this post.
You wouldn't have that problem with a V8!!!!

SRCooper
Committee Members
Posts: 147
Joined: Mon Feb 16, 2015 6:45 pm
Location: Christchurch

Re: LS1 V8 280z

Postby SRCooper » Sun Sep 16, 2018 7:07 pm

New update, sorry its been a while guys my mates have gotten me into dirt biking which takes up a lot of time now aswell as having a hunting pup im training. anyway finally took the 280z out this weekend to Kaikoura on saturday, Turns out i havnt fixed the engine miss fire, it was still missing under load at low revs but drove smoothly in 5th gear there and back without going through any more fuel. so i popped the hood today and pull the spark plugs to see what was wrong, they all seemed fine but then i noticed how stupid i was, turns out the connection in one of the leads had broken off so wasnt even connected. ill get a new set of leads this week probably.
You do not have the required permissions to view the files attached to this post.
You wouldn't have that problem with a V8!!!!


Return to “Members Rides & Projects”

Who is online

Users browsing this forum: No registered users and 6 guests